Arcade Village's blog

Games don't work in Firefox, Google Chrome et Edge

Online games use two technologie to work : Java and Flash.
Arcade Village's games use Java.
Google Chrome since version 45, Firefox since version 52 and Edge don't support this plugin anymore.
You can still play my games with Internet Explorer et Safari.
read the post

Comment are not allowed